We’re currently troubleshooting an issue with Spreadsheet Downloads
Incident Report for CaptivateIQ
Resolved
We have resolved the issue. We are monitoring the situation.
Posted Feb 10, 2023 - 17:11 PST
Identified
We’re currently troubleshooting an issue with Spreadsheet Downloads. We’re working to restore this feature as soon as possible.
Posted Feb 10, 2023 - 16:52 PST
This incident affected: CaptivateIQ Operations.