Issue with Viewing Payout Screens in CIQ

Incident Report for CaptivateIQ

Resolved

This incident has been resolved
Posted Apr 14, 2025 - 09:20 PDT

Monitoring

A fix has been implemented and we're monitoring the results.
Posted Apr 14, 2025 - 08:40 PDT

Identified

We have identified an issue with loading certain pages related to payout processing and worksheets. We are implementing a fix and will update within 30 minutes.
Posted Apr 14, 2025 - 08:30 PDT
This incident affected: CaptivateIQ Incentives (Workbooks & Commission Plans, Payouts).